Zoom recordings not importing
Incident Report for Kaltura
Resolved
What Was the Impact:
Zoom recordings using the older version of Zoom Marketplace integration were not imported into Kaltura between ~9 a.m. UTC October 31st to 9 p.m. UTC November 1st.

Current Status:
We are currently working with individual customers who have upgraded to the latest Marketplace version to reimport Zoom recordings for these dates. As of today, November 9th, we have identified an issue that prevented successful re-imports for some recordings from these dates, however the import was completed successfully for other recordings. Currently this issue is being addressed, and we expect it to be resolved this week. Following this, reimports for these customers who have both upgraded and contacted Customer Care will be completed.

While this reimport process is not yet complete for all customers who have contacted Customer Care, we are working on a case-by-case basis. Each customer’s timeline is different and will be clearly communicated at the case level.

What to Expect Next:
As the original incident on October 31st-November 1st was resolved on November 1st, and since then each customer’s recovery progress is being handled individually by Customer Care, we are closing this Status Page incident post.

With that being said, if your account was impacted by this incident and you have not yet contacted Customer Care, please create a new case so that we can provide you with updates specific to your account.
Posted Nov 09, 2021 - 18:11 UTC
Update
What is the Current Impact:
Zoom recordings using the older version of Zoom Marketplace integration were not imported into Kaltura between ~9 a.m. UTC October 31st until 9 p.m. UTC November 1st.

Current Status:
As previously identified, content was not received for the recordings during this 24-hour time period. Currently there is not yet an identified solution in order to backfill these recordings. The team continues to evaluate options, but it will require more time. HOWEVER, please read the Important section below for a workaround option.

IMPORTANT:
As a workaround to recover and re-upload your account's Zoom recordings immediately, you can upgrade to the latest Zoom Marketplace integration**. After you upgrade, you will need to contact Customer Care in order for us to complete the re-import process on your behalf. Please update an existing case or create a new case on the Customer Care Portal.

Note that the re-import process will be a two-step process done by Kaltura, and will include reimporting content from October 31st to present day, and removing duplicates. So for a short time, you may see duplicate Zoom content until the process has completed running.

Once the process is completed, we will update you via your existing case so you can verify too.

Note: **To update the Marketplace version, simply click “disable” in the integration. Then click “enable” to re-enable it. This will automatically upgrade the version.

Additional setup details here: https://knowledge.kaltura.com/help/kaltura-video-integration-with-zoom-setup-guide

Please let us know if you have any additional questions or concerns!
Posted Nov 04, 2021 - 16:29 UTC
Update
What Is the Current Impact:
Zoom recordings using the older version of Zoom Marketplace integration were not imported into Kaltura between ~9 a.m. UTC October 31st until 9 p.m. UTC November 1st.
Also:
For customers who upgraded their Zoom Marketplace integration to the latest version - the automatically re-import process did not initiate.

Current Status:
Our Engineering team is currently testing a two-step process to complete the re-import on behalf of customers who have upgraded the version. (The process can only be leveraged for the latest Marketplace version.) The process would re-import since October 31st, and then duplicates for November 1st - 3rd would be removed.

What to Expect:
For customers who have both upgraded the Marketplace version and contacted Customer Care, this re-import process will be started after testing is completed. We expect to complete tests by end of day, and to be able to initiate the process within the next 24 hours.

If you have upgraded but not contacted Customer Care, please update an existing case or create a new case on the Customer Care portal so we can run the re-import process once it is ready. Please plan to provide your PID(s).
Posted Nov 03, 2021 - 16:57 UTC
Update
What is the Current Impact:
Zoom recordings using the older version of Zoom Marketplace integration were not imported into Kaltura between ~9 a.m. UTC October 31st until 9 p.m. UTC November 1st.

Current Status:
Our Engineering team has identified that content was not received for the recordings during this 24-hour time period. As a result, there is not currently an identified solution in order to backfill these recordings. The team continues to evaluate options, but it will require more time.

IMPORTANT: In the meantime, to recover and re-upload your account’s Zoom recordings immediately, you can upgrade to the latest Zoom Marketplace integration. The latest version has a built-in automated feature that will process these backdated items, so switching to the latest version will automatically backfill this time period.

To update the Marketplace version, simply disable the integration, and then re-enable it.
Additional setup details here: https://knowledge.kaltura.com/help/kaltura-video-integration-with-zoom-setup-guide

Additionally, our team would be happy to assist you. If you would like to request assistance on the upgrade, please contact Customer Care by creating or updating a case on the CC Portal.

What to Expect Next:
The next update will be provided on Wednesday, November 3rd.
Posted Nov 02, 2021 - 18:29 UTC
Update
What was the Impact:
Zoom recordings using an older version of Zoom Marketplace integration were not imported into Kaltura for a certain time between on or about 09:00 am UTC Oct' 31st until 21:00 UTC Nov' 1st

Current Status:
A hotfix has been deployed yesterday at on or about 21:00 pm UTC, and new Zoom recordings are now processing normally.
At this stage, our engineering team is still working to find a solution to recover the affected recordings that were not uploaded from zoom during the mentioned time above (i.e. prior to the hotfix deployment).

What to Expect Next:
An update on the recovery of recordings issue will be provided by 19:00 pm UTC today
Posted Nov 02, 2021 - 11:52 UTC
Monitoring
What was the Impact:
Zoom recordings using older version of Zoom Marketplace integration were not importing into Kaltura.

Current Status:
A hotfix has been deployed and new Zoom recordings are now processing normally.

What to Expect Next:
An additional task remains to backfill the recordings submitted prior the hotfix deployment. An update on this item will be provided by 12pm UTC on Tuesday.
Posted Nov 01, 2021 - 21:05 UTC
Update
What is the Impact:
Zoom recordings not imported into Kaltura, since Sunday, October 31st. Symptoms include Zoom entries not appearing in KMC.

Current Status:
Our Engineering team has identified the root cause and is currently preparing a hotfix.

What to Expect:
The next update will be provided within 1 hour or as soon as the fix deploys.
Posted Nov 01, 2021 - 20:36 UTC
Identified
Relevant for customers using the older version of Zoom Marketplace integration. (Customers using the newest 2021 version of Zoom Marketplace are not affected.)

What is the Impact:
Zoom recordings not imported into Kaltura, since Sunday, October 31st. Symptoms include Zoom entries not appearing in KMC.

Current Status:
Our Engineering team has confirmed the scope of impact, and is currently working on investigating the root cause. This is a top priority for the team.

What to Expect Next:
The next update will be provided within the next 2 hours.
Posted Nov 01, 2021 - 19:39 UTC
This incident affected: Zoom Integration.