Upload and Database indexing issue
Incident Report for Kaltura
Resolved
What services were impacted: Upload & Database Indexing.

Current Status: The issue is resolved and service is fully resumed with traffic balanced between our two Data Centers as it normally should.

What to expect next: We are closing this incident. If you are still facing any issue please contact our Customer Care team.
Posted Aug 06, 2020 - 12:57 UTC
Monitoring
What services were impacted: Upload & Database Indexing.

What was the impacted: Users faced a problem with completing Upload services to the extent that an upload was successful but the newly uploaded media cannot be found in the KMC or My Media page. Also, users could experience inconsistent results when running search queries

Current Status: issue was due to indexing databases lag between our two data centers. This is mitigated by now by shifting traffic to our East Coast data center. Our engineers are currently working to resume service from the West Coast data center as well.

What to expect next: we are monitoring the service and will report here again in a few hours once service is resumed from both data centers
Posted Aug 06, 2020 - 08:50 UTC
Identified
What services are impacted: Upload, Kaltura API

What is the impact: There is an issue with the Upload service and Kaltura API. Users might experience a successful media upload but the newly uploaded media cannot be found in the KMC or My Media page.

Current Status: Kaltura team has identified the issue with indexing between our Data Centers. In order to mitigate it, the traffic was shifted to the East Coast Data Center. Currently, our engineers are actively working to resolve the issue.
Posted Aug 06, 2020 - 06:13 UTC
Investigating
What service is impacted: Upload

What is the impact: There is an issue with the Upload service. Users might experience a successful media upload but the newly uploaded media cannot be found in the KMC or My Media page.

Current Status: We are investigating the issue and will provide more updates in the upcoming hours.
Posted Aug 06, 2020 - 03:39 UTC
This incident affected: Kaltura API.