Kaltura API issue
Incident Report for Kaltura
Resolved
What was the Impact: Users may have experienced slowness while using or saving changes in KMS, KMC, API, including for playback, uploading files, or while using webcasting.

Current Status: Our engineering team has completed changes and mitigation in order to restore normal performance, and monitoring has been completed. Additionally, AWS confirmed the server load issue has been resolved at their side.

What to Expect Next: Monitoring has been completed and normal performance has been confirmed. This incident is now closed.
Posted Dec 22, 2021 - 15:29 UTC
Monitoring
What is the Impact: Users might experience slowness while using or saving changes in KMS, KMC, API, including for playback, uploading files, or while using webcasting. Specific to upload, the upload process may take longer than usual.

Current Status: Our engineering team has made some changes to mitigate the impact and improve performance. We are currently evaluating and monitoring the service, and seeing improvements to playback and content management.

What to Expect Next: We are monitoring the service speed and will update in the next hour.
Posted Dec 22, 2021 - 14:30 UTC
Identified
What is the Impact: Users might experience slowness while using or saving changes in KMS, KMC, API, including for playback, uploading files, or while using webcasting. Specific to upload, the upload process may take longer than usual.

Current Status: At this stage, our engineering team has identified the issue is related to AWS region server load, and investigation and mitigation efforts by our team are still in progress. Additional information can be seen under the AWS status page for "API Error Rates" here: https://status.aws.amazon.com/

What to Expect Next: We are monitoring the service speed and will update in the next hour.
Posted Dec 22, 2021 - 13:36 UTC
Investigating
What is the Impact: Users might experience slowness while using (saving changes) KMS, KMC, API, Playback, uploading files, or while using webcasting, meaning the upload process may take longer than usual.

Current Status: At this stage, our engineering team is working on a solution as the top priority.

What to Expect Next: Next update in the coming hour
Posted Dec 22, 2021 - 12:46 UTC
This incident affected: Upload (Upload Speed, Upload Process) and Kaltura API, Playback, Kaltura Management Console (KMC), Kaltura MediaSpace.