Intermittent API errors
Incident Report for Kaltura
Resolved
What was the Impact:
Users might have got an error message while trying to use/access data that was created between Jan’ 5th between 9:00 am to 23:00 pm EST.

Such data could have been: Categories, entries, etc.

For example:

1. If the user would try to add a video to the course in a category, that was created during the mentioned date, then he might get an API error accessing this category.
2. User may have got the error while trying to access/open an entry.

Current Status:
Our engineering team confirmed that the restore process of the affected data is completed and the data is available again for a normal operation.

What to Expect Next:
This issue is resolved and will be closed on this Status Page. However, if users are still experiencing any issue accessing data, as always, please don't hesitate to please a support ticket with us
Posted Jan 18, 2022 - 09:13 UTC
Identified
What is the Impact:

Users might get an error message while trying to use/access data that was created between Jan’ 5th between 9:00 am to 23:00 PM EST.
Such data could be: Categories, entries, etc.

For example:

1. If the user will try to add a video to the course in a category, that was created during the mentioned date, then he might get an API error accessing this category.
2. User may get the error while trying to access/open an entry.

Current Status:

Our engineering team had discovered that this issue was caused due to a specific failure during the server backup process that ran on Jan’8th for the data from the time frame that is mentioned above.

Our engineering team is in progress to run a process to restore the affected data. The process will be completed in the next 24 hours. At the end of this process, the data will be available again for a normal operation.

What to Expect Next: The next update will be in 24 hours, or once the fix process is over — the earlier of the two.
Posted Jan 17, 2022 - 15:23 UTC
This incident affected: Kaltura API.