Service Disruption Due to AWS Outage

Incident Report for Kaltura

Resolved

The Kaltura impact from the AWS widespread outage has been mitigated and resolved, all components are functioning as expected.
Posted Oct 21, 2025 - 12:57 UTC

Update

The Kaltura Live service performance degradation has been resolved, we will continue to monitor all components in the upcoming hours.
Posted Oct 20, 2025 - 21:21 UTC

Update

Due to the wide AWS outage, we are seeing some slowness to Kaltura Live on the primary stream. Customers who broadcast to both primary and secondary should not be impacted. Kaltura engineers are working to fully resolve the impacted live components.
Posted Oct 20, 2025 - 20:26 UTC

Monitoring

The affected services have been restored, and we are monitoring system performance to ensure continued stability.
Posted Oct 20, 2025 - 10:14 UTC

Identified

At the moment, Kaltura is evaluating the impact of the AWS-wide outage. We are seeing delays in transcription and transcoding jobs, and in addition, KME is being impacted—specifically in the recording, chat, polls, and whiteboard features.
AWS has reported significant signs of recovery, and most requests are now succeeding, although they are still working through a backlog of queued requests. We are closely monitoring the situation and will continue to provide updates as more information becomes available.
Posted Oct 20, 2025 - 09:49 UTC
This incident affected: Kaltura REACH (captioning service) (Processing Speed), Kaltura Webinars, Virtual Classroom and Meetings (Video Conferencing Features, Recording, Kaltura Meetings), and Transcoding, Live.