Access to Support portal

Incident Report for Kaltura

Resolved

This incident has been resolved.
Posted Sep 16, 2026 - 17:05 UTC

Investigating

Kaltura Customer Portal became unavailable due to Salesforce performance degradation.
More details at: https://status.salesforce.com/current
As a result, users cannot access the support portal: support.kaltura.com

We will provide further updates during the next 60 minutes.
Posted Sep 16, 2026 - 09:47 UTC
This incident affected: Documentation and Customer Care Platforms.