MediaSpace and API degradation

Incident Report for Kaltura

Resolved

Our engineering team identified an issue and implemented a a fix.
Posted Mar 25, 2025 - 14:18 UTC

Identified

We are currently experiencing some slowness in our Video Portal (Kaltura Mediaspace) and Kaltura Events due to issues with our API. Our engineering team is in progress with this issue investigation to identify the root cause and implement a solution as the top priority and will provide an update in the next 60 minutes
Posted Mar 25, 2025 - 13:55 UTC
This incident affected: Kaltura API, Kaltura Management Console (KMC), and Kaltura MediaSpace.