Multiple Zoom recordings made in 1 session ID
Incident Report for Kaltura
Resolved
Current Status:
The second solution, to retroactively address recordings created between November 22nd - December 3rd, has been completed. Earlier today, December 8th, the first stage of the process completed, and all affected entries in this date range were identified. As of 10:45 p.m. UTC, the second stage of the process has completed and all affected entries have been converted back to the original behavior that existed before the implemented change on November 22nd.

What to Expect Next:
Entries and workflow have been restored to original behavior, and this post is now closed.
Posted Dec 08, 2020 - 22:49 UTC
Update
Current Status:
The second solution, to retroactively address recordings created between November 22nd - December 3rd, was previously finalized by our engineering team. As of today, Tuesday, December 8th, the first stage of the process was completed, and all affected entries in this date range have been identified and the list reviewed. Currently, the second stage of the process is now running. This second process will fix the affected entries and convert them back to the original behavior before the implemented change on November 22nd.

What to Expect Next:
The second workflow process is running to fix the affected entries, and the expected completion date/time for this process is by end of day or at the latest by tomorrow morning (UTC time). The next status update on the resolution for retroactive recordings will be posted on Wednesday, December 9th.
Posted Dec 08, 2020 - 17:15 UTC
Update
Current Status:
The second solution, to retroactively address recordings created between November 22nd - December 3rd, has been finalized by our engineering team. A process will run to identify all affected entries in this date range, fix these entries and convert them back to the original behavior before the implemented change on November 22nd.

What to Expect Next:
The workflow process will start to run on Tuesday, December 8th, and the expected completion date for this process is by end of day. The next status update on the solution for retroactive recordings will be posted on Tuesday, December 8th.
Posted Dec 07, 2020 - 18:08 UTC
Update
What was the Impact:
When a user conducted multiple recordings under the same Zoom session ID, and those recording had a different time length, the recordings were imported to Kaltura as a parent and child entries. This affected recordings uploaded between November 22 - noon UTC on December 3rd.

Current Status:
1) The fix has been tested and deployed as of 12:30pm UTC on December 3rd. The solution identifies the timestamps and duration of the recordings in order to upload recordings as separate Entry IDs.

2) The second solution, to retroactively address recordings created between November 22nd - December 3rd, is currently being scoped.

What to Expect Next:
The next update on the solution for retroactive recordings will be posted on Monday, December 7th.
Posted Dec 03, 2020 - 15:38 UTC
Identified
What is the Impact:
When a user conducts multiple recordings under the same Zoom session ID, and those recording have different time length, the recordings are currently being imported to Kaltura as a parent and child entries. This issue was introduced on November 22nd and is currently affecting workflows.

Users might experience:
Unable to identify child Entries in KMC/KMS; some recorded sessions may show an additional recording; chunked Zoom recordings populating as parent/child entries, instead of individual entries.

Current Status:
The root cause and the solution have been identified to address new recordings and the solution is currently in QA. A second solution, to retroactively address recordings created since November 22nd, is currently being scoped.

What to Expect Next:
The solution will be in two phases:
1) Resolve for newly created recordings - currently in QA and is scheduled to deploy by or before Sunday, December 6.
2) Resolve for recordings uploaded between November 22nd and the fix mentioned above - the solution is under evaluation and current ETA is the week of December 7th.

Progress on those 2 solutions and updated timeline will be shared here daily.
Posted Dec 02, 2020 - 17:27 UTC
This incident affected: Zoom Integration.