Upload issue
Incident Report for Kaltura
Resolved
Issue is resolved now.
Posted about 1 month ago. Aug 21, 2019 - 15:28 EDT
Investigating
Our technical team is investigating an issue related to upload. More updates will follow on this page.
Posted about 1 month ago. Aug 21, 2019 - 14:56 EDT
This incident affected: Upload.