Queue management issue
Incident Report for Kaltura
Resolved
Our engineers have increased servers' capacity in the West Coast data center by adding more processing power.
There are longer-term plans to change queue management priorities. These changes will be applied as part of Kaltura’s change management process.
Traffic has been shifted back and is currently balanced between the two data centers. We’re marking this incident as resolved.
Posted Dec 13, 2019 - 10:26 UTC
Monitoring
Our engineers identified an issue with the queue management component in the West Coast datacenter which affected API calls. This issue is related to queue priorities.
As an immediate action, we will add more resources to the queue management component.
Our engineering team is also looking at an option to increase queue efficiency. As this requires more time, we will update about this effort separately.
Currently, all services are fully operational and are running from the East Coast datacenter. We’re expecting to shift traffic back within an hour.
We’re monitoring the service carefully and will continue update on progress.
Posted Dec 13, 2019 - 08:26 UTC
Update
We identified an issue in our West Coast datacenter that affected service availability. Service was affected between 6:48 - 6:58 UTC. As an immediate remedy, we shifted traffic to our East Coast datacenter. Service is now running out of the East Coast datacenter only. We’re still investigating the root cause of this issue. More updates will follow.
Posted Dec 13, 2019 - 07:27 UTC
Investigating
Kaltura is currently investigating an issue with the production environment.
More updates will follow on this page.
Posted Dec 13, 2019 - 06:51 UTC
This incident affected: Kaltura API and Kaltura MediaSpace.